Webhook with http address


I have setup a webhook receiver on AWS, the receiver is running at http://$aws_publick_ip:5000/webhook
If I use this to subscriber a webhook say project_user.update, I do not get any event.
I tried to send the a event from postman to same target, the server received message (which means the server is running fine). I am not sure why I am not getting event from tiledesk, as there is no log. I don’t know where I am going wrong.

note: If I run ngrok at port 5000 locally, it gives https address, I can use that https address for webhook subscription, and I am getting event in that case. Which probably mean that my security group on aws is fine, set to inbound traffic from all IP and outbound traffic to all IPs.

Has anyone tried webhook with http address? Any suggestion on what I might be doing wrong.

you can debug the webhook calls following this guide: https://developer.tiledesk.com/apis/webhooks#debugging-a-webhook

If a webhook isn’t working correctly, failed invocations will be visible using Get the subscriptions logs REST API.

In most cases, the response comes from the third-party service that receives the webhook’s request, not Tiledesk itself. You typically need to work with this service to fix errors.