Error sending email

We installed Tiledesk as docker version on a Debian 11 Bullseye server.
Exim4 is configured to listen on the docker interface ( on port 25. Port 25 is configured in the Tiledesk docker-compose.yml and EMAIL_SECURE is set to false:

If we resend an agent invitation, we get the error:
Error sending email {“error”: {“code”:“ESOCKET”,“command”:“CONN”,“function”:“ssl3_get_record”,“library”:“SSL routines”,“reason”:“wrong version number”}
If I check in root shell with “openssl s_client -connect localhost:25 -starttls smtp” everything is fine.
If I open a shell in the docker container tiledesk-server, I get no error too when trying
openssl s_client -connect -starttls smtp

Duplicate of this Email configurations

the difference to Email configurations is that we have set EMAIL_SECURE=false.

As this is a local smtp server which only listens on localhost, port 465 and 587 are not enabled. It listens only on port 25.

Regarding Email parameters and templates configuration - Tiledesk Developer Hub this should be fine:

EMAIL_SECURE =true #defaults to 587 if is secure is false or 465 if true If true the connection will use TLS when connecting to server. If false (the default) then TLS is used if server supports the STARTTLS extension. In most cases set this value to true if you are connecting to port 465. For port 587 or 25 keep it false.

EMAIL_PORT =25 Is the port to connect to (defaults to 587 if is secure is false or 465 if true)

BTW: I enabled port 465 and set EMAIL_SECURE=true but no mail could be sent too.

We fixed the issue with the new tiledesk-server: 2.3.36.
We just released a new version of the Docker Compose installation with that tiledesk-server version.
Can you try now?
When you try with the new version please delete the old docker-compose.yml file
Thank you for the feedback

1 Like

Hello Andrea,
thank you for the fixed version. Mail sending via local Exim smtp server on port 25 works now fine.

1 Like