# ERROR: firebase config required in tiledesk with rabbitMQ

**URL:** <https://tiledesk.discourse.group/t/error-firebase-config-required-in-tiledesk-with-rabbitmq/43>\
**Category:** Technical issue\
**Created:** [May 12, 2021, 8:48pm UTC](https://tiledesk.discourse.group/t/error-firebase-config-required-in-tiledesk-with-rabbitmq/43 "2021-05-12T20:48:31Z")\
**Posts on this page:** 10\
**Page:** 1

<div class="post-metadata">

**Author:** ![paiva-thiago](https://avatars.discourse-cdn.com/v4/letter/p/f04885/32.png) [@paiva-thiago](https://tiledesk.discourse.group/u/paiva-thiago)\
**Post date:** [May 12, 2021, 8:48pm UTC](https://tiledesk.discourse.group/t/error-firebase-config-required-in-tiledesk-with-rabbitmq/43/1 "2021-05-12T20:48:31Z")

</div>

Hello,

I was trying this [Tiledesk Community version](https://github.com/Tiledesk/tiledesk-deployment/tree/master/docker-compose). I made the deploy, the server is working, but the widget is with some problems. I was trying to embed the widget in a page located in a apache server, that is using another port, and the message below appears in the browser console:

```auto
ERROR Error: firebase config is not defined. Please create your widget-config.json. See the Chat21-Web_widget Installation Page

```

Does Firebase (in blaze plan) still required in this version?

### Update

A detail I forgot to mention - what appears in browser’s console before the error:

```auto
initfirebase::: firebaseConfig 
Object
apiKey: "CHANGEIT"
authDomain: "CHANGEIT"
databaseURL: "CHANGEIT"
messagingSenderId: "CHANGEIT"
projectId: "CHANGEIT"
storageBucket: "CHANGEIT"
__proto__ : Object

```

---

<div class="post-metadata">

**Author:** ![andrealeo](https://avatars.discourse-cdn.com/v4/letter/a/b9bd4f/32.png) [@andrealeo](https://tiledesk.discourse.group/u/andrealeo)\
**Post date:** [May 13, 2021, 2:54pm UTC](https://tiledesk.discourse.group/t/error-firebase-config-required-in-tiledesk-with-rabbitmq/43/2 "2021-05-13T14:54:44Z")

</div>

Please update your Tiledesk docker images to the last version using:

**docker-compose pull**

and after that start it with:

**EXTERNAL\_BASE\_URL=“[http://localhost](http://localhost)” docker-compose up**

as described in the updated README here: [tiledesk-deployment/README.md at master · Tiledesk/tiledesk-deployment · GitHub](https://github.com/Tiledesk/tiledesk-deployment/blob/master/docker-compose/README.md)

---

<div class="post-metadata">

**Author:** ![paiva-thiago](https://avatars.discourse-cdn.com/v4/letter/p/f04885/32.png) [@paiva-thiago](https://tiledesk.discourse.group/u/paiva-thiago)\
**Post date:** [May 13, 2021, 4:06pm UTC](https://tiledesk.discourse.group/t/error-firebase-config-required-in-tiledesk-with-rabbitmq/43/3 "2021-05-13T16:06:37Z")

</div>

Thanks, Andrea!

But now I’ve stumbled in another issue:

The widget is trying to get some resources and is getting 404. I am on my localhost searching for the resource on the server.

```auto
http://localhost:9988/api/609bec8b6848530012f00bc3/widgets
http://localhost:9988/api/609bec8b6848530012f00bc3/labels/PT
http://localhost:9988/api/609bec8b6848530012f00bc3/labels/EN

```

**BUT** this resource is avaliable in the remote server on the 29005 port, where the tiledesk server is listening.

There’s some config where I can force the widget to look to the right location?

---

<div class="post-metadata">

**Author:** ![andrealeo](https://avatars.discourse-cdn.com/v4/letter/a/b9bd4f/32.png) [@andrealeo](https://tiledesk.discourse.group/u/andrealeo)\
**Post date:** [May 13, 2021, 4:21pm UTC](https://tiledesk.discourse.group/t/error-firebase-config-required-in-tiledesk-with-rabbitmq/43/4 "2021-05-13T16:21:40Z")

</div>

What service is installed on 9988 port? and what on 29005?

---

<div class="post-metadata">

**Author:** ![paiva-thiago](https://avatars.discourse-cdn.com/v4/letter/p/f04885/32.png) [@paiva-thiago](https://tiledesk.discourse.group/u/paiva-thiago)\
**Post date:** [May 13, 2021, 5:11pm UTC](https://tiledesk.discourse.group/t/error-firebase-config-required-in-tiledesk-with-rabbitmq/43/5 "2021-05-13T17:11:00Z")

</div>

Port 9988 : apache server, where the page is calling the html widget is

Port 29005: Tiledesk server

---

<div class="post-metadata">

**Author:** ![andrealeo](https://avatars.discourse-cdn.com/v4/letter/a/b9bd4f/32.png) [@andrealeo](https://tiledesk.discourse.group/u/andrealeo)\
**Post date:** [May 13, 2021, 5:39pm UTC](https://tiledesk.discourse.group/t/error-firebase-config-required-in-tiledesk-with-rabbitmq/43/6 "2021-05-13T17:39:39Z")

</div>

> [@andrealeo](#):
>
> EXTERNAL\_BASE\_URL=“[http://localhost](http://localhost)” docker-compose up

So you must run Tiledesk as follow:

**EXTERNAL\_BASE\_URL=“[http://localhost:29005](http://localhost:29005)” docker-compose up**  
Ok?

---

<div class="post-metadata">

**Author:** ![paiva-thiago](https://avatars.discourse-cdn.com/v4/letter/p/f04885/32.png) [@paiva-thiago](https://tiledesk.discourse.group/u/paiva-thiago)\
**Post date:** [May 13, 2021, 6:04pm UTC](https://tiledesk.discourse.group/t/error-firebase-config-required-in-tiledesk-with-rabbitmq/43/7 "2021-05-13T18:04:02Z")

</div>

I’ve tried this before, and the error remains in the browser’s console.

## Update

I forgot the code I’m using to embed in my page:

The code in dashboard was not working, then I changed the `js.src` value:

```auto
 <script type="application/javascript">
         window.tiledeskSettings =
          {
           projectid: "609bec8b6848530012f00bc3"
          };
          (function(d, s, id) {
           var js, fjs = d.getElementsByTagName(s)[0];    
           if (d.getElementById(id)) return;    
           js = d.createElement(s); js.id = id;    
           js.src = "http://here.is.the.address:29005/widget/launch.js";
           fjs.parentNode.insertBefore(js, fjs);
         }(document, 'script', 'tiledesk-jssdk'));
</script>

```

---

<div class="post-metadata">

**Author:** ![andrealeo](https://avatars.discourse-cdn.com/v4/letter/a/b9bd4f/32.png) [@andrealeo](https://tiledesk.discourse.group/u/andrealeo)\
**Post date:** [May 14, 2021, 6:14am UTC](https://tiledesk.discourse.group/t/error-firebase-config-required-in-tiledesk-with-rabbitmq/43/8 "2021-05-14T06:14:25Z")

</div>

> [@andrealeo](#):
>
> **EXTERNAL\_BASE\_URL=“[http://localhost:29005](http://localhost:29005)” docker-compose up**

No If you set **EXTERNAL\_BASE\_URL=“[http://localhost:29005](http://localhost:29005/)” docker-compose up**  
the dashboard automatically update the widget script.

Remember to update before the images with :  
docker-compose pull

and run with :  
**EXTERNAL\_BASE\_URL=“[http://localhost:29005](http://localhost:29005/)” docker-compose up**

If you have problem send us the screenshot

---

<div class="post-metadata">

**Author:** ![paiva-thiago](https://avatars.discourse-cdn.com/v4/letter/p/f04885/32.png) [@paiva-thiago](https://tiledesk.discourse.group/u/paiva-thiago)\
**Post date:** [May 14, 2021, 3:13pm UTC](https://tiledesk.discourse.group/t/error-firebase-config-required-in-tiledesk-with-rabbitmq/43/9 "2021-05-14T15:13:41Z")

</div>

I made this call

```auto
EXTERNAL_BASE_URL=“http://localhost:29005” docker-compose up

```

and the script in the dashboard remains like the image below

(and the widget is not working, even if i put ` js.src` with the value `"http://here.is.the.address:29005/widget/launch.js"`)  
 ![Screenshot_2021-05-14 Tiledesk Support Dashboard](https://global.discourse-cdn.com/free1/uploads/tiledesk/original/1X/2e3591f352b0541952860153152df55f68c627e2.png)

---

<div class="post-metadata">

**Author:** ![paiva-thiago](https://avatars.discourse-cdn.com/v4/letter/p/f04885/32.png) [@paiva-thiago](https://tiledesk.discourse.group/u/paiva-thiago)\
**Post date:** [May 15, 2021, 11:06pm UTC](https://tiledesk.discourse.group/t/error-firebase-config-required-in-tiledesk-with-rabbitmq/43/10 "2021-05-15T23:06:31Z")

</div>

Hey Folks!

I’ve solved this problem doing two things:

1. `docker-compose pull` as @andrealeo said;
2. Instead of `EXTERNAL_BASE_URL="http://localhost" docker-compose up`, I called using the remote address and its port, something like this: `EXTERNAL_BASE_URL="http://the.remote.address.online:PORT_NUMBER" docker-compose up`

And the widget worked!

Thanks @andrealeo for your help!
